Wednesday, August 1, 2018

Developers: Your new app on the Play Store must target API level 26

Android App Bundle Google Play Dynamic Delivery

When Google first brought the Android OS to market, the company had a laissez-faire approach to developers. After all, the company needed to entice developers to bring their apps and services to the fledgling platform. However, many of these early decisions were later walked back on as they resulted in a poor user experience—turns out allowing apps to do whatever they wanted resulting in apps doing whatever they wanted. With the newer releases of Android, apps are unable to spam notifications, use background services without explicitly notifying the user, access sensitive permissions without a dialog granting permission, and much more. Yet, Google made it easy for apps to bypass these user-friendly restrictions by allowing apps to continue targeting older SDK versions. Last December, Google announced that all new applications submitted to the Google Play Store must target at least API level 26 (Android 8.0 Oreo). It is finally August, which means that if you are working on a new app and plan on submitting it to the Play Store, it better target Android 8.0 Oreo!

August 2018 – All New Apps Must Target API Level 26

Google has given you plenty of time to make adjustments to your application to meet the new requirements. Bringing up your application to a newer API level will be for the benefit of yourself down the road as well as your users. Your users will enjoy the fact that your app behaves consistently with other apps on their device, whereas you'll save yourself some headache as next year Google will increment the targetSdkVersion requirement. If you dilly-dallied and waited to update your app to meet this requirement, then take note that after one year following the release of Android P, the new targetSdkVersion requirement will be API level 28 or higher.

Google isn't trying to punish you by forcing you to expend effort in keeping your app updated. The company just wants you to help keep your users' devices secure by ensuring that you use all of the latest APIs and permission requests. If you are worried that users with older devices won't be able to enjoy your app, then you'll be glad to know that there isn't a floor for the minimum SDK version you can set. As for developers who already maintain one or more applications on the Play Store, your app must target API level 26 by November 2018 if you want to be allowed to submit updates to your app on the Play Store.



from xda-developers https://ift.tt/2M5b9fJ
via IFTTT